[inizio] [indice generale] [precedente] [successivo] [indice analitico] [contributi]


350. PostgreSQL

350.1 Messaggio di errore: Unsupported frontend protocol con Postgres

Ho due PC collegati in rete, uno ha Red Hat 5.2 ed un altro la Debian GNU/Linux 2.1 Volevo condividere lo stesso archivio mediante PostgreSQL. Sul server (dove sta l'archivio) ho lanciato il demone postmaster con l'opzione -i.

All'atto però di connettermi all'archivio con:

psql -h 192.168.1.1 db_name

riscontro il seguente errore:

Connection to database 'nome_db' failed.
Unsupported frontend protocol.

Da che dipende?

È un problema di compatibilità tra le due versioni di Postgres.
Devono necessariamente essere le medesime. Le due distribuzioni hanno
infatti versioni diverse.

D: Roberto Kaitsas
R: Stephane Bortzmeyer

---------------------------

LDR --- Copyright © 1999-2000 Gaetano Paolone --  bigpaul @ pluto.linux.it


[inizio] [indice generale] [precedente] [successivo] [indice analitico] [contributi]